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How can I correct an ION "Translator Failure" error?

Issue
A machine is showing errors within the System Log Events of 'Translator failure'

Product Line
ION Enterprise
Struxureware Power Monitoring
Power Monitoring Expert


Environment
Translators

Cause

This issue can occur for custom Modbus Device Importer (MDI) translators, Device Type Editor (DTE) translators,  or built in system translators. The error message will mention a specific device.

In many situations this can be ignored and considered a by-product of a communication issue. In other instances, the translator files may have been modified and incorrect syntax used.


Resolution

As a workaround, the translator files can be replaced with those from a working system.


1) Determine the device type and locate the translator file.

translator file directories:

Native Modbus Devices (PM8, CM4250, etc.) - ...\ION Enterprise\system\translators
Custom Modbus Devices - ...\ION Enterprise\config\translators

Native Modbus Devices (PM8, CM4250, etc.) - ...\Power Monitoring Expert\system\translators 
Custom Modbus Devices - ...\Power Monitoring Expert\config\translators 

2) Stop the ION Network Router Service
3) Rename the .ion and .xml files for the device type to .old
4) Locate a clean copy of the translator files above from another system at the same version. If the device type is custom it will have to be recreated through the MDI or DTE.

5) Place these files in the same directory and restart the stopped ION services
6) Check the device to ensure communications are stable and errors are no longer coming into the System Log

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